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PREFACE

RMT water characterisation software provides a topographical interpretation of flow and water quality

data by utilising the X- and Y-Co-ordinates of a given catchment area. The unique interface allows the

User full control of the visual appearance of their water quality data, producing images suitable for

reports and presentations.

The Program was developed as an add-on to many of the water quality models currently in use today,

but can also be used independently with raw water quality data.
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GETTING STARTED WITH RMT

Hardware and Software Requirements

RMT has been developed for both 16 and 32-bit operating systems, using Visual Basic language. In order

to take full advantage of RMT’s exciting features the following hardware and software configuration is

required as a minimum:

• Operating System :- Windows 95 And Windows NT

• Minimum Processor :- 486MHz (Pentium Recommended)

• Minimum Ram :- 4 MB ( 8 MB Recommended )

• Hard Disk Space: - 5 MB for Initial Installation.

Installation Process

1. Insert Disk One into the floppy disk drive, here denoted as a: drive.

2. In Windows 95, click on the Start Button and select Run from the Start Menu.

3. In the dialogue box, enter the following command: a:\setup

Chapter
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4. Follow the on screen instructions.
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INTRODUCTION TO RMT

RMT can effectively transform tables of incomprehensible water quality data into maps designed for

maximum visual impact. More importantly, RMT can be used as a River Management Tool for evaluating

results from the many water quality models in use today.

Features of RMT

The map created using RMT provides a visual representation of a given catchment area, with the width of

the river representing flow and the colour of the lines representing the concentration of the chosen

pollutant.

The database utility used to create files for RMT can handle data on up to sixteen parameters, as well as

water quality indices and biological indices. Please note, however, that data is not required for all of the

parameter fields. In this event, empty fields should simply be filled with zeros. The database utility

requires two data files, the structure of which is described in the following section.

RMT also incorporates a useful zoom utility: left clicking the mouse allows you to zoom in on any area of

the map. By right clicking the mouse button, the map will zoom out to its full size. You can also specify a

single river or reach to be plotted out.

Chapter
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In order to increase the sensitivity of the map to changes in quality data, RMT incorporates a utility to edit

the value associated with each colour, or to change the designated colours used for each parameter.

Once you have created a map, you may want to enhance the appearance of the output file. For this

purpose RMT includes tools for adding titles, including a grid or altering the appearance of the

background. This last enhancement is especially useful as it allows you to create a bitmap file, which could

consist of labels or even a scanned image of a map of the surrounding area.

RMT also contains a facility for plotting the location of monitoring stations, flow stations and discharge

points on the map. The data for this facility is contained in the STATION DATA FILE, the structure of

which is outlined below. For each of the records entered in this file, RMT plots a symbol representing the

feature on the map. By clicking on any one of these symbols, a description of the feature will be given.

Once you have obtained the desired look for your map, you can choose to print the file. This opens up a

Report file in a separate window, which can either be sent to an attached printer or exported in several file

formats.

Data Requirements

In order to run RMT, two files are required: the INPUT DATA FILE and the STATION DATA

FILE. These files are comma delimited files (.csv) and can be created using a Spreadsheet Program such

as Microsoft’s Excel. You can choose to plot up to sixteen parameters and chemical or biological indices,

but empty columns should be filled with zeros. The structure of these files is outlined in Chapter Three,

Structure of Data-files.
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SETTING UP DATABASE FILE

The file system used in RMT is based on a database structure. A facility for creating a database from a

series of files is included with the Program, thus eliminating the need for a separate database Program.

The following chapter will describe how to use this facility to create input files for RMT.

Structure of Data-files

The following section describes the structure of the two input files required to run RMT, namely the

INPUT DATA FILE and the STATION DATA FILE. These files are comma delimited files (.csv)

and should be created using a Spreadsheet Program such as Microsoft’s Excel.

When constructing the input data-file, you can either number each river individually or separate the river

into reaches. Each Parameter must have a value, and must be separated by a comma. You can choose to

plot data for any number of the available parameters, but any empty columns should be filled with zeros.

INPUT DATA FILE: This file is a comma delimited (.csv) file that can easily be created using a

Spreadsheet Program. The following column headers (from left to right) can define the structure of this

file, which should not be included in the final .csv file. The value of the X and Y Co-ordinate can be

derived from any Grid Reference System, as RMT simply takes the largest co-ordinate values and uses

them to position your map on-screen.

Chapter
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• RIVER OR REACH NUMBER

• X-CO-ORDINATE

• Y-CO-ORDINATE

• FLOW

• SUSPENDED SOLIDS

• BIOCHEMICAL OXYGEN DEMAND

• PERMANGANATE VALUE

• DISSOLVED OXYGEN

• TEMPERATURE

• PERCENTAGE SATURATION

• AMMONIA

• TOTAL OXIDISED NITROGEN (TON)

• PHOSPHATE

• pH

• ALKALINITY

• CHLORIDE

• TOTAL HARDNESS (TH)
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• NITRITE

• NITRATE

• CONDUCTIVITY

• WATER QUALITY INDICES

• BIOLOGICAL INDICES

STATION DATA FILE: This file is also a comma delimited (.csv) file that can easily be created using a

Spreadsheet Program. This file is used to plot the location of monitoring stations, gauging stations and

discharges on the map. The following column headers can define the structure of this file, which should

not be included in the final .csv file.

• RIVER OR REACH NUMBER

• SITE IDENTIFICATION(i.e. monitoring, gauging or effluent)

• SITE NUMBER

• SITE NAME

E X A M P L E  I N P U T  D A T A  F I L E

 1,979,909,3.98,0,0.3,0,1.7,0,0,0.03,0,0,0,0,0,0,0,10.85,0,0,0

 1,977,908,3.98,0,0.4,0,1.6,0,0,0.05,0,0,0,0,0,0,0,10.25,0,0,0

 .....................

 15,595,356,61.59,0,2.1,0,4.2,0,0,1.2948,0,0,0,0,0,0,0,9.3643,0,0,0
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• X-CO-ORDINATE

• Y-CO-ORDINATE

After

the

data-

files

have

been constructed in a spreadsheet environment, you should save the data-file, using the save as

option in the file menu in the spreadsheet program. Name the data-file and then select the

comma-delimited or .csv format from the file type list.

Creating a New Database

Once you have created the two input files described in the previous section you are ready in create a

database (.mdb) file.

1. From the File Menu, choose the Create New… option.

2. Next select the comma delimited (.csv) file which contains your INPUT data. The Program

will read the input data into the database.

3. Finally select the comma delimited (.csv) file that contains the STATION data. The Program

will read the station data into the database.

<

E X A M P L E  S T A T I O N  D A T A  F I L E

 1,Monitoring,head,SOURCE,980,908

 1,Monitoring,ms1,DOWNSTREAM,957,810

 .....................

 15,Effluent,S.3.3.,RIVER END,613,376
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Once you have created the database file you are ready to plot your first RMT map file. Chapter Four

describes each of the features of RMT. Instructions on running RMT for the first time will also be

given.
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DETAILED DESCRIPTION OF RMT

Introduction

The features of RMT are described in detail in the following chapter In order to understand some of the

terminology used in this chapter, you are assumed to have a basic understanding of  the Windows 95

environment.

Description of Features

THE FILE MENU

The File Menu provides the facilities required to create a new database, open and closes files or print a

report file. There now follows a summary of each of the items found in the File Menu.

By selecting the Create New ...  option from the File Menu, you can create a new

database from existing data. Two data-files are required to create a database, the

structure of which has been discussed in Chapter 3.

The Open option from the File Menu is used to open an existing Map database. The

program will ask you to specify the location of the existing  .mdb  database. Once this has

been done, the RMT software will read in the data from the database file and plot the map

in black. You can now choose which Parameters to plot from the Parameter Menu.

Chapter

4

Create New ...

Open
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Use the Close option on the File Menu to close the existing map. You do not have to

save the map file as any changes are automatically saved to the database file.

The Print option on the File Menu is used to send the map file to an attached printer

or save the contents in a range of file formats. The Map can be printed in Portrait

format on an A4 Sheet of Paper. When you first select this option, the program will take

about 1 minute to write the Map to the report software, at which point a print window

should appear. This Print window is the RMT software link to the Printer and can be maximised by

clicking the maximised button on the top right corner. The icons provided can perform the following

functions.

1.  MAGNIFYING GLASS: Preview the full page before printing.

2.  PRINTER: Send the contents of the .RMT file to the default Printer.

3.  SUITCASE: Save the contents in a range of file formats for export to other applications.

4.  MAIL: Send the file as email.

5.  CLOSE: Exit the Print window and return to the RMT Program.

Use the Exit option on the File Menu to exit the RMT Program.

Any changes made to the Map data or settings are saved to the Map database as soon as

the changes are made, so you can safely exit the RMT software without having to save

Close

Print

Exit

<
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any changes.

THE VIEW MENU

The View Menu allows you to include a grid with the map and also plot flow, monitoring and effluent

discharge points on the map. You can also choose whether to view the full map or specify a single reach

or river to be plotted out. There now follows a summary of each of the items found in the View Menu.

By selecting the Grid option on the View Menu an 8 by 8 grid will be displayed across the

Map. This allows easy reference of points of interest on the Map by using the grid

references.

The Stations option on the View Menu allows the location of stations to be viewed on the

Map. By selecting the Station type(s) and clicking OK, each station will be plotted on the Map

with one of the following symbols:

By left clicking the mouse when the mouse pointer is over a station, the station data for that
particular station is show in a window. By clicking on this window, the window disappears.

Grid

Stations

8

 Station TypeStation Type SymbolSymbol

Flow station

Monitoring station

Effluent station
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By selecting the Whole Map option on the View Menu after you have viewed part of a

Map, you will be returned to viewing the entire map.

The Part Map option on the View Menu allows viewing of individual rivers or

reaches. The RMT software displays a window, asking you to input the river or reach

number of the river to plot. After entering the required number and clicking on OK,

the individual river or reach will be displayed.

Whole Map

Part Map

8
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You can also zoom in on the Map by positioning the mouse at the desired location and left

clicking the mouse, or zoom back to the original Map by right clicking the mouse.

THE SETTINGS MENU

The Settings Menu allows you to select that parameters are to be activated for the current map. You can

also edit the values associated with each colour on the scale along the bottom of the screen for each

individual parameter. The Settings Menu can also be used to alter the colour of the grid or alter the

appearance of the background. This is particularly useful as a bitmap (.bmp) file can be used as a

background, allowing you the opportunity to include further information with the map. Finally you can

add a title to their map which will appear on the task-bar as well as in the report file. There now follows a

summary of each of the items found in the Settings Menu.

The Parameter Settings option on the Settings Menu allows you to select

which parameters can be displayed on the Map. A window is displayed, and you

should select the required Parameters by clicking the option box next to the

Parameter once. At this stage a tick will be displayed, denoting the Parameters

that have been activated.

Parameter Settings
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The Colour Values option on the Settings Menu allows you to change the colour for

values, up to, but not including the value specified in each field for each parameter. To

change a colour, click on Change Colour at which point a colour window will be

displayed.  From this window you should select the new colour, by clicking on the

desired colour and clicking on OK. Use the forward (>,>|) and back (|<,<) controls

to navigate through the colour values, and click on the text box for any parameter value

you wish to edit. After modifying the parameter value(s), click on Close to write the

changes to the current database. This action will not affect any other database, which

will retain their original colour values.

The Grid Colour menu option on the Settings Menu allows you to change the grid

colour being displayed. A window will be displayed allowing you to choose the colour

from a range of colours. Click the box containing the new colour, and then click OK.

The new colour should now be shown when the grid is displayed.

The Map Background option on the Settings Menu can be used to alter the

appearance of the map background. When selected, a colour window will be displayed,

from which you should select the desired colour and press OK. The Map Background

will now change to the new colour selected.

The Map Title option on the Settings Menu can be used to attach a title to the Map.

When selected a window with a text box appears. After entering the title for the map

and clicking on OK, the new title will be shown at the bottom right hand side of the

status bar, and written to the database. When the database is loaded in the future, the

new title will be shown each time, until changed again by the user.

Colour Values

Grid Colour

Map

Background

Map Title
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THE PARAMETERS MENU

The Parameters Menu allows you to switch between each of the activated parameters. Parameters can

be activated using the Parameters Settings option on the Settings Menu. Activated parameters are

highlighted in bold. The parameters that can be plotted with RMT are as follows:

• SUSPENDED SOLIDS

• BIOCHEMICAL OXYGEN DEMAND

• PERMANGANATE VALUE

• DISSOLVED OXYGEN

• TEMPERATURE

• PERCENTAGE SATURATION

• AMMONIA

• TOTAL OXIDISED NITROGEN (TON)

• PHOSPHATE

• pH

• ALKALINITY
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• CHLORIDE

• TOTAL HARDNESS (TH)

• NITRITE

• NITRATE

• CONDUCTIVITY

• WATER QUALITY INDICES

• BIOLOGICAL INDICES

THE HELP MENU

The Help Menu contains access to RMT’s Help file and information about the RMT.

THE STATUS BAR

The Status Bar is found along the bottom of the window and contains information on the progress of a

file transfer, the name of the open file, the view and the title of the map file.

THE COLOUR SCALE

The Colour Scale is found along the top of the status bar. On entering the Program the values attached

to each of the defined colours are given a value zero. Once the database has been read in the colour scale

attached to each parameter will be displayed when the activated parameter has been selected. When

creating a new database, the colour scale has to be defined before the data can be plotted out.
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Running RMT for the First Time

Once you have created your first database (.mdb) file, as outlined in Chapter 3, you are ready to use

RMT for the first time. The following section takes you through the procedure for plotting out your first

map using RMT.

1. From the File Menu, choose Open and click on your .mdb file. Click on Open. The Program

will plot out your map file. Its progress is recorded on the left of the Status Bar.

2. From the Settings Menu, choose the Parameter Settings option and select the parameters you

have entered data for in your input data file.

3. If you wish to edit the colour values on the scale then select the Colour Values option on the

Settings Menu and  edit the values as described in Description of Features, Settings Menu.

4. Select the parameter you wish to plot by clicking on the Parameter Menu and identifying the

parameter you wish to plot. The Program will then plot the chosen parameter’s data with the

allocated scale displayed on top of the Status Bar.

5. You can then use any of the features discussed in Description of Features to add a grid, title,

plot stations or plot a particular river for closer inspection.

6. When you have finished, go to the File Menu and select the Print option. The program will

take about one minute to write the map to the report software, at which point a print window
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should appear. You can then choose to print the file or export the file using various file

formats as discussed above.

W H E N  Y O U  H A V E  F I N I S H E D  U S I N G  R M T  C H O O S E  T H E  E X I T  O P T I O N  F R O M  T H E

F I L E  M E N U .  R M T  -  R I V E R  M A P P I N G  T O O L

V E R S I O N  1 . 0

P R O G R A M :  K E N N E T H  R .  M C A L P I N E

C O N C E P T :   J A N E T T E  M C A L P I N E

E M A I L :  I N F O @ S C I S O F T W A R E . C O M


